CINELERRA EN GUTSY 7.10, EL MEJOR EDITOR DE VIDEO (ACTUALIZADO 27 DIC 2007)


Cinelerra actualmente está considerado como sino el mejor, uno de los mejores editores de video del mundo, y como no open source. (PROBADO EN FEISTY Y GUTSY)

Bueno, visto lo visto y los problemas para instalar cinelerra he decidido reunificar mis posts y realizar uno para definitivamente explicar la instalación de cinelerra en UBUNTU GUTSY. Voy a explicar dos metodos, uno compilando y otro desde unos archivos preparados.
Vamos allá:

METODO 1: COMPILACIÓN (basado en http://ubuntuforums.org/showthread.php?t=623589 )
1 Instalamos el paquete subversion mediante el comando:
sudo aptitude install subversion
2 Ahora chequeamos el código fuente de cinelerra mediante el siguiente comando desde el terminal:
svn checkout svn://svn.skolelinux.org/cinelerra/trunk/hvirtual

3 Instalar las dependencias para compilar cinelerra, que no son pocas, mediante el comando:
sudo apt-get install g++ git-core cogito subversion automake libtool nasm x11proto-xf86vidmode-dev libxv-dev libxxf86vm-dev libogg-dev libvorbis-dev libtheora-dev libopenexr-dev libdv-dev libpng12-dev libjpeg62-dev libtiff4-dev libfreetype6-dev libsndfile1-dev uuid-dev libasound2-dev libavutil-dev libmpeg3-dev libavcodec-dev libx264-dev libfaac-dev libmjpegtools-dev fftw3 fftw3-dev liba52-0.7.4-dev liblame-dev libfaad2-dev libesd0-dev libiec61883-dev libavc1394-dev

4 Una vez instalados hay que introducirse en el directorio de cinelerra (cd hvirtual) y ejecutar el comando:
./autogen.sh
Después:
./configure
Después
make
Y por último si no te salen errores:
sudo make install
Ya tenemos cinelerra instalado.
5 Según postean hay que hacer un par de cositas más para que funciones correctamente, hay que reinstalar dos archivos:
Primero los desinstalamos
sudo apt-get –purge remove faad libfaad2-0
Ahora los volvemos a instalar:
sudo apt-get install faad libfaad2-0

Una vez realizado esto deberias pasar a NOTAS COMUNES A LAS INSTALACIONES.

*PD: me gustaría indicar que aunque me comentan que funciona el METODO 1 no lo he probado personalmente, yo instalé el EL METODO 2

METODO 2: DESDE PAQUETES PRECOMPILADOS (METODO PROPIO)

Primero descargamos el siguiente archivo Cinelerra.tar.gz de aquí http://rapidshare.com/files/73194458/Cinelerra.tar.gz.html.
(Son los arhivos del repsoitorio giss, que funcionaban perfectamente antes de la última actualización.)
Lo extraemos bien desde consola (tar -xj…), bien pulsando boton derecho del raton y seleccionando extraer aquí (…más sencillo imposible…).

Instalamos las librerias fftw3 libmjpegtools0c2a libfaac0 libopenexr2c2a, mediante el comando:
sudo aptitude install fftw3 libopenexr2c2a libmjpegtools0c2a libfaac0
Ahora solo nos queda instalar los paquetes extraidos (del archivo Cinelerra.tar.gz), bien mediante gdebi, bien mediante consola. Si los instalais mediante gdebi según cual instaleis primero os dará error y tendreis que instalar otro antes, no obstante creo que sería mejor hacerlo mediante consola, ingresando en el directorio donde tenemos los cuatro archivos “.deb” descomprimidos y instalándolos mediante el comando:
sudo dpkg -i *.*

******************************************** NUEVO – AÑADIDO 27 -12 – 2007 ********************************************************
METODO 3: Desde Repositorios (Documentación extraída de http://cvs.cinelerra.org/getting_cinelerra.php y también probado y funcionando)

1 Trabajar con el repositorio.

Modificar el archivo sources.list de la siguiente forma:
sudo gedit /etc/apt/sources.list
Añadir la siguiente línea al final (copia y pega) y después guarda el archivo
deb http://repository.akirad.net akirad-gutsy main
Conseguir la clave gpg del repositorio. Teclea en un terminal:
wget -q http://repository.akirad.net/dists/akirad.key -O- | sudo apt-key add –
Actualizar la lista de repositorios:
Primero tecleamos: sudo apt-get update
Despues cuando termine: sudo apt-get upgrade

2 Elegir la opcion de nuestro procesador. Estos repositorios tienen varios paquetes disponibles según el procesador y si posees o quieres dar soporte opnegl o no de tal forma que tendremos los siguientes paquetes:
– cinelerra (sin opengl) (para todos los procesadores)
– cinelerra-generic (con opengl) (para todos los procesadores)
– cinelerra-k8 (con opengl) (para procesadores amd)
– cinelerra-k7 (sin opengl) (para procesadores amd)

3 Instalar: Para instalar el que más os guste podeis utilizar bien el gestor de paquetes synaptic, hoy lo voy a explicar con synaptic así que nos vamos a sistema – administración – gestor de paquetes synaptic, metenos la contraseña, le damos a la pestaña de buscar tecleamos cinelerra. Seleccionamos el paquete que más nos convenga e instalamos. Y ya está, según indican en la página estos paquetes vienen ya con el parche del kernel (shmmax to 0x7fffffff) y con soporte de idioma según la instalación base (que más quieres!!!!!!!!!!!)
De todas formas si os indica lo del kernel y no lo teneis en castellano, pues nada nos vamos a las NOTAS COMUNES A LA INSTALACION y ya está.

NOTAS COMUNES A LAS INSTALACIONES. (Excepto Metodo 3)
Una vez realizada una de las dos instalaciones tenemos que efectuar unos pasos adicionales común a ellas:
1- El kernel de GNU/Linex sólo permite 32MB de memoria compartida, insuficiente en su caso para cinelerra, po lo que es más que probable que cuando inicieis el programa te dé este error:
void Mwindow::init_shm0:WARNING:/proc/sys/kernel/shmmax is 0×2000000, which is too low. Before running Cinelerra do the following as root: echo “0×7fffffff” >/proc/sys/kernel/shmmax

2- Así que para arreglarlo en una terminal nos logueamos como root:
sudo su
(metemos nuestra contraseña) y a continuación tipeamos:
echo “0×7fffffff” >/proc/sys/kernel/shmmax
Bueno aquí gracias a Juan (uno de los lectores del blog) he podido comprobar que por el cambio de kernel, puede ser que no funcione y de error este paso, así que simplemente a los que no les funcionen sigan el primer paso al pie de la letra (…es decir, loguearnos como root: sudo su) y ahora tipear el siguiente comando:
sysctl -w kernel.shmmax=2147483647
y solucionado.

3- Para que éste cambio quede de forma permanente hay que retocar el archivo /etc/sysctl.conf de la siguiente manera:
sudo gedit /etc/sysctl.conf
Añadimos al final:
kernel.shmmax=0x7fffffff

4 Por último, lo TRADUCIMOS AL CASTELLANO, porque nos sale en inglés:
Retocamos el siguiente archivo:
sudo gedit /var/lib/locales/supported.d/local
Añadimos la siguiente línea a las que haya antes de en_EN:
es_ES ISO-8859-1
Guardar el fichero y reconfigurar los lenguajes:
sudo dpkg-reconfigure locales
En el menú de Gnome-Administracion-Soporte de Idiomnas seleccionamos
“Español España”.

Y ya está tenemos el mejor editor de video de linux y quizás del mundo y como no de código abierto instalado en nuestra máquina.
Un pequeño manual para utilizar cinelerra y no morir en el intento aquí

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s